1. Гость, мы просим Вас ознакомиться с Правилами Форума и Отказом от ответственности!

Не работает php на Ubuntu server 16.04.

Тема в разделе 'Общее', создана пользователем steel, 25 авг 2017.

  1. TopicStarter Overlay

    steel Пользователи

    Сообщения:
    39
    Лайки:
    2
    Репутация:
    0
    Приветствую!
    Столкнулся со странной штукой, то что работало раньше на Ubuntu 14. Закинул файлики от реги/lk в www и радуйся, сейчас не пашет на Ubuntu server 16.04.
    При этом html работает, php не хочет ни в какую. Кто что может посоветовать?
  2. ГрУбОсТь Пользователи

    Сообщения:
    111
    Лайки:
    34
    Пол:
    Мужской
    Репутация:
    2
    Страна:
    Ukraine Ukraine
    даунгрейд на 14 версию, но я в этих делах не оч, сижу на 14 себе спокойно
  3. Samuel Пользователи

    Сообщения:
    159
    Лайки:
    72
    Пол:
    Мужской
    Репутация:
    -5
    Ты решил посты набить, или что? Ещё бы из-за того, что 32 либы не ставятся предложил даунгрейднутся до 32 битной системы.
    Какая версия php (php -v)? Что по логам?
  4. this Пользователи

    Сообщения:
    38
    Лайки:
    68
    Репутация:
    1
    Команда:
    Utwig
    Иногда в конфигурационном файле php.ini параметр short_open_tag имеет значение Off, при котором короткие теги <? ... ?> не работают, требуется вот такая их запись <?php ... ?>. Рекомендую убедиться, какая форма записи используется в ЛК, скорее всего короткая, возможно потому и не работает.
    PS ...после изменения параметра на short_open_tag = On рекомендую перезапустить apache.
  5. TopicStarter Overlay

    steel Пользователи

    Сообщения:
    39
    Лайки:
    2
    Репутация:
    0
    Пока не помогло, поставил все On, даже также прописал 1 раз "short_open_tag = On", но тоже не помогло.
    2017-08-26_193913.jpg 2017-08-26_193924.jpg
    --- добавлено: 26 авг 2017 в 17:48 ---
    ДЦ, где обычно брал серв, сейчас выдает на загрузку только 16ю, 17ю Ubuntu.. Вот и решил потренироваться, а там нечаянная заморочка. И на 10й хорошо сиделось)))
    Последнее редактирование модератором: 3 сен 2017
  6. Nooo Пользователи

    Сообщения:
    10
    Лайки:
    1
    Пол:
    Мужской
    Репутация:
    0
    libapache2-mod-php установлен?
  7. FoxiBoy Пользователи

    Сообщения:
    3
    Лайки:
    1
    Пол:
    Мужской
    Репутация:
    0
    Ну так возьми и поставь, и настрой все человеку на 16 убунте, и php.mysql.apache. и обясни человеку как что работает совместимости в отличии от 14, а не третируй
    Mentalist нравится это.
  8. BergForce Пользователи

    Сообщения:
    91
    Лайки:
    5
    Пол:
    Мужской
    Репутация:
    -3
    Страна:
    Russian Federation Russian Federation
    поставь Debian 8 и не парься, убунту - шлак.
Черновик сохранён Черновик удалён
Similar Threads
  1. aToMiX
    Ответов:
    1
    Просмотров:
    379
  2. vladimp

    Ubuntu

    vladimp, 3 июл 2013, в разделе: Архив
    Ответов:
    4
    Просмотров:
    398
  3. ramsheart
    Ответов:
    2
    Просмотров:
    323
  4. Shaman
    Ответов:
    7
    Просмотров:
    467
  5. Neron
    Ответов:
    5
    Просмотров:
    675
Загрузка...

Поделиться этой страницей